• FIRST AND LAST NAMES ARE REQUIRED WHEN REGISTERING

Bought a 2nd 128 today, but it needs some help..

Help Support IH Cub Cadet Forum:

Joined
Feb 22, 2022
Messages
19
Location
Northumberland, Pennsylvania
Hello everyone,

Today I purchased a 2nd CC128. It came with a mowing deck, loaded rear tires, wheel weights, chains, custom heavy-duty hitch, and a plow. Motor is excellent, starts right up and idles perfectly. I'm the tractor's 2nd owner!

The seller claimed the tractor had a new clutch. The clutch engages fine, but there is a terrible noise coming from underneath me when I push the pedal down about 1/2 way, or when it's idling/driving at full RPM. If I push the pedal down part way, the noise goes away. Sounds like an extremely loud rattling.

If this were a car, I'd look to a throw-out bearing. Does that sound like a possibility?

I'll have pictures of it tomorrow. Thanks for reading!

PS. When I asked the seller if he knew anything about the noise.. he blocked me on FB (I bought it on Marketplace). So.. yeah.

~Tom
 

digger

Administrator
Staff member
Administrator
Moderator
IHCC Sponsor
Joined
Jun 22, 2002
Messages
15,749
Location
Park Rapids Mn.
displayname
Digger
Hello everyone,

Today I purchased a 2nd CC128. It came with a mowing deck, loaded rear tires, wheel weights, chains, custom heavy-duty hitch, and a plow. Motor is excellent, starts right up and idles perfectly. I'm the tractor's 2nd owner!

The seller claimed the tractor had a new clutch. The clutch engages fine, but there is a terrible noise coming from underneath me when I push the pedal down about 1/2 way, or when it's idling/driving at full RPM. If I push the pedal down part way, the noise goes away. Sounds like an extremely loud rattling.

If this were a car, I'd look to a throw-out bearing. Does that sound like a possibility?

I'll have pictures of it tomorrow. Thanks for reading!

PS. When I asked the seller if he knew anything about the noise.. he blocked me on FB (I bought it on Marketplace). So.. yeah.

~Tom
Check for a broken teaser spring or make sure that the anti-rattle springs are still there. Could also be a throw out bearing issue.
 

dschwandt

Well-known member
Joined
Mar 31, 2012
Messages
4,375
displayname
David Schwandt
Fully inspect the drivetrain from the engine on back to the transmission.
Anything that looks to be suspect may be the culprit.
My guess would be what Charlie noted.
Repair and/or replace as needed.
 

mgwin

Well-known member
Joined
Sep 3, 2009
Messages
2,789
Location
Reidsville, NC
displayname
Marty A. Gwin
Uh huh, second what Charlie and David said. Congrats on another 128. That was my first cub.
As for the FB/Marketplace, I have messaged several people concerning buying cubs. The next thing I know, they have deleted the listing. I even messaged one person within an hour of the post, asking when I could come to look at it. Never heard anything else from them.
 
Joined
Feb 22, 2022
Messages
19
Location
Northumberland, Pennsylvania
Thanks all for the replies. After taking the center cover off, I was able to see what was making that terrible sound. I've attached a picture that shows what is vibrating. Any idea how to secure it with more than just cotter pins?

The tractor came with decent loaded tires with chains, but I have a brand-new pair of 23X10.5-12 AGs to put on it. I might have those filled and will definitely keep the weights.
 

Attachments

  • IMG_20220320_204604722_HDR.jpg
    IMG_20220320_204604722_HDR.jpg
    79.3 KB · Views: 117
  • IMG_20220320_204625645_HDR.jpg
    IMG_20220320_204625645_HDR.jpg
    105 KB · Views: 118
  • IMG_20220320_204642310.jpg
    IMG_20220320_204642310.jpg
    111.1 KB · Views: 105
  • IMG_20220320_204651124_HDR.jpg
    IMG_20220320_204651124_HDR.jpg
    114.5 KB · Views: 103

dschwandt

Well-known member
Joined
Mar 31, 2012
Messages
4,375
displayname
David Schwandt
Clutch hanger and release lever need bushed and new pin installed. Possibly the release lever may need refaced as well.
Make sure the return spring is not rusted in two.
 
Joined
Feb 22, 2022
Messages
19
Location
Northumberland, Pennsylvania
Thanks everyone. Still learning about these clutch-driven systems. I took the frame cover off, and while running, the driveshaft seems to spin slightly out-of-round. I'm sure it's making contact with the drive plate, causing it to vibrate like crazy. Not sure if the shaft is bent or what. I'm studying the service manual as we speak... I appreciate the help! I'm looking forward to the days where I can assist others, as I feel like a fish out of water! Thankfully I have my other 128 to compare to.
 

Latest posts

Top