• FIRST AND LAST NAMES ARE REQUIRED WHEN REGISTERING

782D journey

IH Cub Cadet Tractor Forum

Help Support IH Cub Cadet Tractor Forum:

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
I am starting this thread to document the technical and cosmetic restification of my newly purchased 782D.

782d2-jpg.148652


First on the agenda: this thing does not start well when "cold". It has the original starter and glow plugs. The glow plug indicator in the dash is fubar. I have done some research on this and think I will be going this route:

Do away with the original style glow plugs and buy the NGK Y-103V / 2031 updated units.

s-l500.jpg


To properly power these up, more voltage than originally engineered will be required. I'll add a continuous duty relay, such as a glow plug relay from a mid 80's Ford F250 diesel:

s-l1600.jpg


I know a lot of guys use a Ford style starter relay, but I don't think they will last long term because they are a intermittent use relay.
 

snicklas

Well-known member
Joined
Jul 1, 2007
Messages
798
Location
Greenfield, Indiana
displayname
Scott Nicklas
That relay should do what you need. That is the glow plug relay for A 7.3 IDI Ford/IH Diesel. That powers 8 glow plugs for ~10-15 seconds… the 3 for your 782D should be a cake walk.

(One of my other hobbies is Ford Diesels, so I recognize that by sight… lol)
 

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
Did some work on it this evening. Located the oil crankcase dipstick. It was difficult to see, so I cleaned it and shot it in yellow. Also, that annoying pipe stack is gone, and the muffler is mounted the proper way. I need the heat shields, shield mounting screws, and a correct tip clamp to button that up. Oil and filter needs to be changed now. It reads to be a quart high!

782d6.jpg


782d7.jpg
 

Jay Fetters

Well-known member
IHCC Supporter
Joined
Jan 26, 2021
Messages
299
Location
U.P. Michigan
Looks like a beautiful machine! And I'm one of the rare people that absolutely can't stomach diesels, of any kind. I hate they way they sound, the way the oil smells, the way the oil is always dirty, and the way they all sound like they are ready to rattle apart. And the exhaust smell is the worst! But that one appears to be a well cared for unit, and while it's in your care, she will only get better! Nice find...
 

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
I changed the oil and filter-bought the recommended stuff at the local Kubota dealer. I hooked up the oil sender wire, and the oil light stays on until about mid throttle, then goes out. Engine sounds great. Will add a mechanical SW oil pressure gauge and relocate the hour meter under the hood. I will also replace the oil pressure switch just in case it is faulty. After all of that, it decided to shear off a driveshaft pin. So those are on order.
 

Jay Fetters

Well-known member
IHCC Supporter
Joined
Jan 26, 2021
Messages
299
Location
U.P. Michigan
That's how it seems to go with a new to you cub. My 1862 has been 1 thing after another, but the end is in sight! My 1650 was the same way, years of neglect, some got sorted out right away on inspection, other things had to be fixed as they reared their head. It is just how it seems to go, sadly....
 

mgonitzke

Well-known member
Joined
Aug 4, 2006
Messages
4,247
Location
Wichita, KS
displayname
Matt Gonitzke
Oil pressure light on mine goes out as soon as it starts. I think I'd want to see what the oil pressure actually is before doing too much more with it, in case there is actually a problem that needs to be solved.

These are very hard on the OEM driveshaft. I'd recommend either a CV joint driveshaft or 2000/3000 series driveshaft.
 

Attachments

  • IMG_20191224_152633.jpg
    IMG_20191224_152633.jpg
    88.4 KB · Views: 92

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
Any idea if the D600 has the issue with the aluminum camshaft plugs falling out like some of the older Kubota engines? Also will check the relief valve if the sending unit does not fix the issue.
 

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
Does anyone know the size of the retaining rings for the frame mounted hydraulic ports? The MTD number is 716-3014. Pictured below is the fitting that the ring attaches to and the rig keeps the fitting snug to the frame.

727-3014.jpg
 

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
Really would prefer not to remove it from the tractor. Should be a standard size-just inquiring if anyone knows what it is off the top of your head.
 

mgonitzke

Well-known member
Joined
Aug 4, 2006
Messages
4,247
Location
Wichita, KS
displayname
Matt Gonitzke
Since it looks like they are sticking way out of the frame and aren't seated, so why not measure the OD of the part that goes through the hole in the frame? That will be the size external snap ring you need.
 

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
Starter and electrical upgrade has been performed. It cranks a lot better now. I used 2 AWG for the positive cable. I cleaned all grounds. The 40A circuit breaker looked crusty, so I cleaned it for now, and ordered a new one. I also replaced the oil pressure switch with a new OEM Kubota part. The OP light still acts the same. Next is to remove and inspect the relief valve.

CUBOTA1.jpg
CUBOTA2.jpg


CUBOTA3.jpg
CUBOTA4.jpg
 

dgeary

Well-known member
Joined
Jun 7, 2013
Messages
49
displayname
Dennis Geary
Starter and electrical upgrade has been performed. It cranks a lot better now. I used 2 AWG for the positive cable. I cleaned all grounds. The 40A circuit breaker looked crusty, so I cleaned it for now, and ordered a new one. I also replaced the oil pressure switch with a new OEM Kubota part. The OP light still acts the same. Next is to remove and inspect the relief valve.

View attachment 148730 View attachment 148731

View attachment 148732 View attachment 148733
You may want to consider putting an oil pressure gauge on the engine before getting into it too far. It's possible there may be an electrical connection issue with the OP sender circuit.
 

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
Well I found the culprit. The pressure relief check ball was missing! I pulled the insert out of the housing and all that was there was the spring. Three local dealers did not have the 11/32" steel check ball on hand-said it would be a week before they would have this 23 cent part. I had the idea that these steel check balls are commonly used in older auto transmission valve bodies. So a search yielded the info that a 11/32" steel check ball was used in Chrysler 727 Torqueflites. The local transmission guy had one on hand, and didn't charge for it. So I installed it, and replaced the oil filter. Just cranking it over to start it, the OP light went out and stayed out. I ran it for a few minutes, and no leaks or oil lights. A dash mounted gauge is on the to do list. The image below is the of the new check ball after I reassembled it.

cubota5.jpg
 

1811Cub

Well-known member
Joined
Jul 13, 2020
Messages
641
Location
Elkland, PA
Like what you're doing to bring the 782D back to life.
I was wondering what is supposed to keep that check valve ball from falling out each time you replace the oil filter or is that why the original was missing?

Initially, I pulled out the insert easily with a pick. It was an interference fit, albeit a bit loose. Upon installation, I staked the aluminum cover with a punch to prevent the check ball and insert from popping out. Theory is that at some point when the filter was being replaced, the spring pressure popped the insert out, and the ball was lost. When a previous owner put the spring back in and the insert, they might have not known about the check ball. Then when the engine was started, the oil light was illuminated. When they couldn't figure it out, they disconnected the oil switch, and the light was out.. Obviously not a good way to "fix" the issue. The mere fact that this engine survived this long is a testament to the Kubota design. I really don't think any damage was done to it. There was no glitter in the oil, and no weird noises to suggest bearing damage. A oil pressure reading will prove this. Next project is the glow plug system upgrade.
 
Top